$re = '/[^\.]+[.][^\.]+[.][^\.]+[.]((?:Gross|Tare)Calibration)+[.][^\.]+[.][^\.]+?(\s*)/';
$str = 'abc.ac.b.GrossCalibration.qualcosa.c
abc.ac.b.TareCalibration.qualcosa.c
abc.ac.b.CiaoCalibration.qualcosa.c
abc.ac.b.NoCalibration.qualcosa.c
abc.ac.b.Calibration.qualcosa.c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);