import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<func>[a-zA-Z_]\\w+)\\s*(\\((?>[^()]+|(?2))*\\))";
final String string = "var someVar = myValue; object.subob\n"
+ "ject.function(with, some = obj.func(a, b[2][1]), arguments); return true;\n"
+ "// or\n"
+ "var someVar = myValue; object.subobject.function(with, some = obj.fu\n"
+ "nc(a, b[2][1]), arguments); return true;\n"
+ "// or\n"
+ "var someVar = myValue; object.subobject.funct\n"
+ "ion(with, some = obj.func(a, b[2][1]), arguments); retun true;\n"
+ "// and so on";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}