re = /Windows\sNT\s10.0;\s(Win64|WOW64)/
str = 'Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/59.0.3071.115 Safari/537.36'
# Print the match result
str.match(re) do |match|
puts match.to_s
end