using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z0-9-]+(?:_[0-9]+){2}\..+$";
string input = @"MATCH
file_123_456.txt
DON'T MATCH
f?()1_dwj_weq.txt
file_123_456.
file.txt
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}