#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\{NUMBER(?<format>\:[^\}]*)?\}"
Local $sString = "ZNK{NUMBER:D10}" & @CRLF & _
"ZNK{NUMBER}" & @CRLF & _
"ABC-{NUMBER:D10}{NUMBER:D5}{NUMBER}-XYZ"
Local $sSubst = "{0$1}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)