import Foundation
let pattern = #"^file *"?([^" ]*)"[\s\S]*?((?:{[\s\S]*?)*?}[\s\S]})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##############################################################################"""
#############################################################################
# DB substitution file generated by http://github.com/epics-containers/ibek #
#############################################################################
file "$(IOCSTATS)/db/iocAdminSoft.db" {
pattern
{ "IOC" }
{ "BL01T-EA-TST-02" }
}
file "$(IOCSTATS)/db/iocAdminScanMon.db" {
pattern
{ "IOC" }
{ "BL01T-EA-TST-02" }
}
file "$(ADSIMDETECTOR)/db/simDetector.template" {
pattern
{ "P", "R", "PORT", "TIMEOUT", "ADDR" }
{ "BL01T-EA-TST-02", ":DET:", "DET.DET", "1", "0" }
}
file "$(ADCORE)/db/NDPva.template" {
pattern
{ "NDARRAY_PORT", "ADDR", "SCANRATE", "NDARRAY_ADDR", "ENABLED", "P", "R", "TIMEOUT", "PORT" }
{ "DET.DET", "0", "I/O Intr", "0", "0", "BL01T-EA-TST-02", ":PVA:", "1", "DET.PVA" }
}
file "$(ADCORE)/db/NDStdArrays.template" {
pattern
{ "NDARRAY_PORT", "FTVL", "ADDR", "SCANRATE", "NELEMENTS", "NDARRAY_ADDR", "ENABLED", "P", "R", "TIMEOUT", "TYPE", "PORT" }
{ "DET.DET", "CHAR", "0", "I/O Intr", "1048576", "0", "0", "BL01T-EA-TST-02", ":ARR:", "1", "Int8", "DET.ARR" }
}
file "simDetector.pvi.template" {
pattern
{ "P", "R" }
{ "BL01T-EA-TST-02", ":DET:" }
}
file "NDPluginPva.pvi.template" {
pattern
{ "P", "R" }
{ "BL01T-EA-TST-02", ":PVA:" }
}
file "NDPluginStdArrays.pvi.template" {
pattern
{ "P", "R" }
{ "BL01T-EA-TST-02", ":ARR:" }
}
"""##############################################################################
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)