using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:rgb(?:a|)\s*|#)(?:\(|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2})(?:\,|)(?:\,|)\s*(25[0-5]|2[0-4][0-9]|1[0-9]?[0-9]?|[1-9][0-9]?|[0-9]|[A-Fa-f0-9]{2}|[A-Fa-f0-9]{2}).+";
string input = @"
#3498db
rgb(231, 76, 60)
rgb(155, 89, 182)
rgba(46, 204, 113,1.0)
rgba ( 52, 152, 219,1.0)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}