// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ca[0-9_]+|[a-z]+\.csv").unwrap();
let string = "c://dev-dl-data-d2-us=east-1-5148727/all/stage/clinical/cro/raw/c/ca209_040/2018/08/02/aesae.csv";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}