use strict;
my $str = '30 $m^2$
4,000 km
';
my $regex = qr/\b(?<number>[\d,]+(?:\.\d+)?)(?<space> ?|&[^;]{2,7};)(?<dimensions>(?:(?<mathjax>\$[^\n\$]+\$)|(?<unit>(?:Y|Z|E|P|T|G|M|k|h|da|d|c|m|µ|n|p|f|a|z|y)?(?:m|g|s|A|K|mol|cd|Hz|N|Pa|J|W|C|V|F|Ω|S|Wb|T|H|lm|lx|Bq|Gy|Sv|kat|l|L))))/mp;
my $subst = '$<number> $<dimensions>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";