$re = '/([^,-]+)(-[^,-]+)?/';
$str = 'UMC12I-1234,CSM3-123,VQ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);