using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"asignarValores\('([^']*)', '([^']*)', '([^']*)', '([^']*)', '([^']*)', '([^']*)', '([^']*)'\)";
string input = @"asignarValores('agregarDeudaCarroCompra', '12345678', '01', 'INS', '2009', '2', '0')
asignarValores('uno', 'dos', 'tres', 'cuatro', 'cinco', 'seis', 'siete')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}