use strict;
my $str = 'Tue Sep 14 08:57:47 2021
Thread 1 advanced to log sequence 186 (LGWR switch)
Current log# 2 seq# 186 mem# 0: D:\\ORADB\\DV1\\REDO02A.LOG
Current log# 2 seq# 186 mem# 1: H:\\ORADB\\DV1\\REDO02B.LOG
Tue Sep 14 09:07:40 2021
Thread 1 advanced to log sequence 187 (LGWR switch)
Current log# 3 seq# 187 mem# 0: D:\\ORADB\\DV1\\REDO03A.LOG
Current log# 3 seq# 187 mem# 1: H:\\ORADB\\DV1\\REDO03B.LOG
Tue Sep 14 09:22:09 2021
Thread 1 advanced to log sequence 188 (LGWR switch)
Current log# 4 seq# 188 mem# 0: D:\\ORADB\\DV1\\REDO04A.LOG
Current log# 4 seq# 188 mem# 1: H:\\ORADB\\DV1\\REDO04B.LOG
Tue Sep 14 09:38:03 2021
Thread 1 advanced to log sequence 189 (LGWR switch)
Current log# 1 seq# 189 mem# 0: D:\\ORADB\\DV1\\REDO01A.LOG
Current log# 1 seq# 189 mem# 1: H:\\ORADB\\DV1\\REDO01B.LOG';
my $regex = qr/^(\w{3}\s{1}\w{3}\s{1}\d{2}\s{1}\d{2}\:\d{2}\:\d{2}\s{1}\d{4})?((\r||.|\n)*)(?=(\w{3}\s{1}\w{3}\s{1}\d{2}\s{1}\d{2}\:\d{2}\:\d{2}\s{1}\d{4}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}