const regex = new RegExp('^0001[\\s]*(.*?)[\\s]*([\\d,.]*)[\\s]*(\\d{6})', 'gm')
const str = `0001 Basic Salary 4,408.00 200801`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}