#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*\b[A-Za-z]{2}\d{2}(?!\d)\w*"
Local $sString = "it is ZZ10ASDJN123 and ZZ100DD22"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)