$re = '~,?\s*\"(\\\\.|[^\"])+\"\s*:\s*null~m';
$str = '{"a": null}
{"a": 123, "b": null}
{"a": 123, "b": null, "c": "foo"}
{"a": 123, "b": null, "c": "foo", "blby\\"nazov": false}
{"a": 123, "b": null, "c": "foo", "blby\\"nazov\\"null hodnotou": null, "d": 1}
{"a": 123, "b": null, "c": "foo{\\"x\\": null}", "d": 1}
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;