use strict;
my $str = 'http://www.stackoverflow.com?a=1&b=2
http://www.stackoverflow.com?a=2&b=3&order_by=old_data
http://www.stackoverflow.com?a=2&b=3&order_by=old_data&c=4
http://www.stackoverflow.com?order_by=old_data&a=2&b=3
http://www.stackoverflow.com
$1new_sort$2$3';
my $regex = qr/^(.+order_by=).+?(&|$)(.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}