re = /\A(?i:urn:(?!urn:)(?<nid>[a-z0-9][a-z0-9-]{1,31}):(?<nss>(?:[-a-z0-9()+,.:=@;$_!*'&~\/]|%[0-9a-f]{2})+)(?:\?\+(?<rcomponent>.*?))?(?:\?=(?<qcomponent>.*?))?(?:#(?<fcomponent>.*?))?)\z/
str = 'urn:example:a123,0%7C00~&z456/789?+abc?=xyz#12/3'
# Print the match result
str.match(re) do |match|
puts match.to_s
end