$re = '/^[+-]?(?:0|[1-9]\d*)(?:\.\d+)?$/m';
$str = 'VALID
+1
-1
1
+1.0
-1.0
1.0
+0.01
-0.01
0.01
+111.111
-111.111
111.111
INVALID
+-0
00
01
1.1.1
1,0
abc
1.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);