$re = '/https?:\/\/(\w+\.)?imgur.com\/(\w*\d\w*)+(\.(png|jpg|gif|PNG|JPG|GIF|jpeg))?/i';
$str = '
https://imgur.com/gallery/kbRSjdw
test
https://i.imgur.com/zeOe49Q.jpeg
https://i.imgur.com/2M7LmOO.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);