const regex = /\b\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{4}$', 'gm')
const str = `Nov 2020
Dec 2020
Jan 2021
Feb 20201
Mar2021
Apr 2021`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}