using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)<(category) name=""Content Server Categories:(.+?)"">(.+?)</(category)>";
string substitution = @"<$1-$2 name=""Content Server Categories:$2"">$3</$1-$2>";
string input = @"<category name=""Content Server Categories:FOLDER:test category"">
<attribute name=""test attribuut""><![CDATA[test]]></attribute>
<attribute name=""test attribuut1""><![CDATA[test1]]></attribute>
</category>
<category name=""Content Server Categories:FOLDER1:FOLDER2:test category"">
<attribute name=""test attribuut""><![CDATA[test]]></attribute>
<attribute name=""test attribuut1""><![CDATA[test1]]></attribute>
</category>
<category name=""Content Server Categories:FOLDER NAME:test category"">
<attribute name=""test attribuut""><![CDATA[test]]></attribute>
<attribute name=""test attribuut1""><![CDATA[test1]]></attribute>
</category>
<category name=""Content Server Categories:FOLDER NAME: FOLDER NAME1:test category"">
<attribute name=""test attribuut""><![CDATA[test]]></attribute>
<attribute name=""test attribuut1""><![CDATA[test1]]></attribute>
</category>
<category name=""Content Server Categories:FOLDER:test category name"">
<attribute name=""test attribuut""><![CDATA[test]]></attribute>
<attribute name=""test attribuut1""><![CDATA[test1]]></attribute>
</category>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}