\"the literal " (3410 / 428 / 2216)
-- starting hand the literal text -- starting hand (case sensitive) \#the literal # (3510 / 438 / 2316)
Group handnum(?P<handnum>\d+) \d+a Unicode decimal digit, repeated at least once
the literal (3210 / 408 / 2016)
\(the literal ( (4010 / 508 / 2816)
id: the literal text id: (case sensitive) Group handid(?P<handid>[a-z0-9]+) +matches at least one character from the set below:
a-zone character from a (9710) to z (12210) (case sensitive)
0-9one character from 0 (4810) to 9 (5710)
\)the literal ) (4110 / 518 / 2916)
\(the literal ( (4010 / 508 / 2816)
Group gametype(?P<gametype>.*?) .*?any Unicode character (except for line terminators), repeated any number of times
\)the literal ) (4110 / 518 / 2916)
the literal (3210 / 408 / 2016)
\(the literal ( (4010 / 508 / 2816)
dealer: the literal text dealer: (case sensitive) \"the literal " (3410 / 428 / 2216)
\"the literal " (3410 / 428 / 2216)
Group buttonplayer(?P<buttonplayer>.*?) .*?any Unicode character (except for line terminators), repeated any number of times
\"the literal " (3410 / 428 / 2216)
\"the literal " (3410 / 428 / 2216)
\)the literal ) (4110 / 518 / 2916)
\"the literal " (3410 / 428 / 2216)
,the literal , (4410 / 548 / 2C16)
Group handutc(?P<handutc>.*?) .*?any Unicode character (except for line terminators), repeated any number of times
,the literal , (4410 / 548 / 2C16)
Group handseqno(?P<handseqno>.*$) .*any Unicode character (except for line terminators), repeated any number of times
$end of line
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string