# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=Legal Description:)(\n)(.*)^(?:(?!Property Use:).)*"
test_str = ("General Info\n"
"Status: Certified\n"
"ACCOUNT\n"
"Property ID:\n"
"408123\n"
"Geographic ID:\n"
"Type:\n"
"P\n"
"Agent:\n"
"LETS GO TAX SERVICES - PO BOX 111\n"
"(Authorized)\n"
"Legal Description:\n"
"AREA THAT I WANT TO CAPTURE\n"
"Property Use:\n"
"OWNER\n"
"Name:\n"
"ABCD GAME SERVICE LLC\n"
"Secondary Name:\n"
"ATTN ACCTS PAYABLE\n"
"Mailing Address:\n"
"PO BOX 2222 NEW YORK NY 222515-12354\n"
"Owner ID:\n"
"123456")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.