import Foundation
let pattern = #"^(?:(?=(\1.|)(.))){1,850}?(?!.*\2.*\2)\1\K\2"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"b|Q.W'Gdo1[nX'p>hjF/!@)7\j?L*@dAB$`nR5wQ&jaR{`C"Zbi,cWe/<jwX]sL7GQ`S>^fr~xuP1w%I|:AW!MwTi~rAq?>a&7-5x46q"^@G>JB.~=WbIB}GC:"?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}