import Foundation
let pattern = #"(?P<text>.*?)(?P<index>{ *{ *([^}{]+?) *} *})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Мы вынуждены отталкиваться от того, что высокотехнологичная концепция общественного уклада обеспечивает актуальность{{1}}приоритизации разума над эмоциями. В своём стремлении повысить качество жизни, они забывают,{ {1}} что семантический разбор внешних противодействий, в своём классическом представлении, допускает внедрение стандартных подходов. В своём стремлении повысить качество жизни, они забывают, что современная методология разработки создаёт необходимость включения в производственный план целого ряда{{1} } внеочередных мероприятий с учётом комплекса кластеризации усилий. Непосредственные участники технического прогресса ограничены исключительно образом мышления. Каждый из нас понимает очевидную вещь: { {1 7 7} }выбранный нами инновационный путь способствует подготовке и реализации приоритизации разума над эмоциями.{{ 1} }"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)