use strict;
my $str = 'Generalken0b Generalken0bi generalken0b
General
ken0b
Generalk3n0b
Generalkenob
G3neralkenob
ggggggggggg0 ggggggggggG0 GeneralKen0b
A5abcdefghij - match
dasdaA4avxsa - match
AA5sssaaaaaa - no match
A55asdasdasa - no match
ab5DaeFsasfg - no match';
my $regex = qr/(?=\b.{12}\b)(?=\b[a-z0-9]*[A-Z][a-z0-9]*\b)(?=\b[a-zA-Z]*[0-9][a-zA-Z]*\b)\b\w{12}\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}