import re
regex = re.compile(r"""
\[\[(
# link, and optional anchor
(?<link>[^\|\#\]]+)?(\#(?<anchor>[^\|\]]+))?
# display title (optional)
(\|(?<title>[^|\]]+))?
# tooltip (optional)
(\|(?<tooltip>[^|\]]+))?
)\]\]
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("# Entry\n\n"
"## Definition\n"
"A published announcement made by a trusted [[Emitter]], detailing an event that occurred on their platform. \n\n\n"
"## Specifications (3.0)\n"
"#v3_0 \n\n"
"A trustlist entry follows a basic structure, with parts being omitted during ingest, as these are filled by the receiving [[Directory]], responsible for the good tenure of this entry, and its correlation to existing data.\n\n"
"As SocialGuard 1.0 to 3.0 tied its data to the [Discord](https://discord.com) [[Platform]], all data types are bound to that end.\n\n"
"| Property | Type | Description | Requirement |\n"
"| -------- | ---- | ----------- | ----------- |\n"
"| `id` | Guid | ID of the entry. | Set by API |\n"
"| `userId` | UInt64 | ID of the receiving [[User]]. | Required |\n"
"| `entryAt` | DateTime | Date/Time at which the entry was emitted on the [[Directory]]. | Set by API |\n"
"| `lastEscalated` | DateTime | Date/Time at which the entry was last escalated/edited. | Set by API |\n"
"| `emitterId` | String | ID of the [[Emitter]] responsible for this Entry. | Set by API |\n"
"| `emitter` | [[Emitter#Specifications (3.0)]] | Details of the [[Emitter]] responsible for this entry. | Set by API |\n"
"| `escalationLevel` | [[#Range: Escalation level (3.0)]] | Escalation/Severity level of the events indicated by this entry. | Required |\n"
"| `escalationNote` | String | Details of the event that led to this entry. | Required |\n\n"
"### Range: Escalation level (3.0)\n"
"This range defines the severity of an event leading to an entry. It is ranged by severity level and ordered from lowest to highest severity :\n\n"
"1. **Suspicious**\n"
" The [[User]] is marked as suspicious. Their behaviour should be monitored.\n"
"2. **Untrusted**\n"
" The [[User]] is marked as untrusted. It is advised to exercise caution when interacting with them.\n"
"3. **Blacklisted**\n"
" The [[User]] is deemed dangerous. Banning this user is greatly advised.\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")