$re = '/(?!(\S*s){4}|(\S*t){2}|(\S*a){2}|(\S*i){2}|(\S*n){2}|(\S*l){2}|(\S*e){2})\b[stainless]+\b/m';
$str = 'Found Words : stainless, stain, net, ten, less, sail, sale, tale, tales, ants
Unacceptable words to find : tent, tall
Acceptable words to find : less
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);