$re = '~(?|(?P<ALL>.*(?P<ID>\bH-\d{4}\b).*)|(?P<ALL>.+))~';
$str = 'Sample line with H-5722 id
Sample line without id';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);