#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<a>.*)(?<b>[0-9]\.[0-9]*$)"
Local $sString = "*Material, name=Porosity_Hardin_Beckermann" & @CRLF & _
"*Elastic, dependencies=1" & @CRLF & _
"210000.000000000, 0.300000000, 0.000000000" & @CRLF & _
"189625.778743714, 0.293220339, 0.020000000"
Local $sSubst = "${a}, ${b}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)