package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(.*?)>`)
var str = `Francesco Renga <francesco_renga-001@gmail.com>, Marty McFly <mmcfly@gmail.com>
Marty McFly <mmcfly@gmail.com>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}