use strict;
my $str = '[105.68 - 143.759] some text
[143.759 - 173.88] some texT
[173.88 - 201.839] some text
[0.88 - 201.839] some text
[173.88 - 201.839]no space
[01.88 - 201.839] some text
[0.88 - 2.01.839] some text
[0.88 - .201839] some text
[173.88 - 201.839[ some text';
my $regex = qr/\[(0.\d+|[1-9]\d*\.\d+)\D+(0.\d+|[1-9]\d*\.\d+)\] *(.*)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}