import Foundation
let pattern = #"\[(0.\d+|[1-9]\d*\.\d+)\D+(0.\d+|[1-9]\d*\.\d+)\] *(.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
[105.68 - 143.759] some text
[143.759 - 173.88] some texT
[173.88 - 201.839] some text
[0.88 - 201.839] some text
[173.88 - 201.839]no space
[01.88 - 201.839] some text
[0.88 - 2.01.839] some text
[0.88 - .201839] some text
[173.88 - 201.839[ some text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)