re = /^\s*(<([^\s<>]+)[^<>]*>)Apple<\/\2>/m
str = '<div class="tn-atom" field="tn_text_1584898828640" target="_blank">Apple</div>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end