package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^#]*(bbb|ccc)|^`)
var str = `echo aaa bbb ccc ddd eee`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}