#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "-?0+\.(0)+\b|\.0+\b|\b0+(?=\.\d*[1-9])|\b0+(?=[1-9]\d*\.)|(\.\d*?)0+\b"
Local $sString = "00.00" & @CRLF & _
"00002.0" & @CRLF & _
"3.00" & @CRLF & _
"-4.0" & @CRLF & _
"0.00" & @CRLF & _
"-0.00" & @CRLF & _
"0.03" & @CRLF & _
"2.01" & @CRLF & _
"0.001" & @CRLF & _
"-0.03" & @CRLF & _
"101" & @CRLF & _
"0.001" & @CRLF & _
"-0.03" & @CRLF & _
".50" & @CRLF & _
"00.00" & @CRLF & _
"11.000000"
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)