$re = '/-?0+\.(0)+\b|\.0+\b|\b0+(?=\.\d*[1-9])|\b0+(?=[1-9]\d*\.)|(\.\d*?)0+\b/';
$str = '00.00
00002.0
3.00
-4.0
0.00
-0.00
0.03
2.01
0.001
-0.03
101
0.001
-0.03
.50
00.00
11.000000';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;