using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*sources\s*: \[\s*""(.*?)""";
string input = @"<script type='text/javascript'>var player = new Clappr.Player({
sources: [""https://stream246.uqload.com/3rfkvsgbgrw2q4drdjh7flnhb2lf6ff2m6pnbxhevplrwbk2snkkbvddzajq/v.mp4""],
preload: 'none',
poster: ""https://stream246.uqload.com/i/05/00307/jge6igyfdjim_xt.jpg"",
width: ""100%"",
height: ""100%"",
disableVideoTagContextMenu: true,
parentId: ""#vplayer""
});";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}