const regex = /\s*sources\s*: \[\s*"(.*?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*sources\\s*: \\[\\s*"(.*?)"', 'gm')
const str = `<script type='text/javascript'>var player = new Clappr.Player({
sources: ["https://stream246.uqload.com/3rfkvsgbgrw2q4drdjh7flnhb2lf6ff2m6pnbxhevplrwbk2snkkbvddzajq/v.mp4"],
preload: 'none',
poster: "https://stream246.uqload.com/i/05/00307/jge6igyfdjim_xt.jpg",
width: "100%",
height: "100%",
disableVideoTagContextMenu: true,
parentId: "#vplayer"
});`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}