package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)robert (.+) palmer`)
var str = `robert eric palmer sent for the boat
robert eric william palmer sent for the boat
robert eric palmer palmer sent for the boat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}