import Foundation
let pattern = #"(\w*)(?:\w{4,}$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"TESTTESTTESTT"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"SSSS"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)