$re = '/(?<=total\s-)\s+(\S+)/m';
$str = 'Data is private total - 54545.58';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);