package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https:\/\/[a-z\.]+.kaspersky-labs\.com\/[0-9A-Z\-]+\/main\.js`)
var str = `https://gc.kis.scr.kaspersky-labs.com/3AB9A552-5B01-8648-A873-82DD69063EB6/main.js`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}