$re = '/^.*?(\(.*\))?$/m';
$str = 'DECIMAL
DECIMAL(14,5)
RAND(1)
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;