using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]?\d+(?:\.\d+)?(?:\s{1,10}|\\n)(?:[A-Z][a-z]+ ?)+";
string input = @"3.1 Introduction
3 Battery
3.1\nIntroduction
A1 Introduction
A1.1 String
B3 Battery Tests
I3.1 Etc";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}