#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\b\w)(\s)(?=\w\b)"
Local $sString = "j j winston a b williams" & @CRLF & _
"hb d party supplies e g" & @CRLF & _
"t t ice cream z z specialists"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)