import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^.\\n]*[^\\/\\n]*\\.\\K[^\\/\\n]+";
final String string = "https://www.example.org/\n"
+ "http://example.com/\n"
+ "ca.gov\n"
+ "http://blade.example.com/bikes/airplane.php\n"
+ "http://alarm.example.com/\n"
+ "smugmug.com\n"
+ "shop-pro.jp\n"
+ "https://example.org/\n"
+ "qq.com\n"
+ "pcworld.com\n"
+ "symantec.com\n"
+ "360.cn\n"
+ "http://example.com/?brother=bike\n"
+ "http://www.example.com/behavior/bead.php\n"
+ "army.mil\n"
+ "https://example.com/boy/bedroom.php\n"
+ "https://example.com/\n"
+ "https://www.example.com/brother?activity=believe\n"
+ "https://www.example.net/achiever/bottle.html\n"
+ "http://believe.example.com/bit?bait=base&bone=ball\n"
+ "aboutads.info\n"
+ "http://www.example.com/\n"
+ "http://www.example.edu/afternoon\n"
+ "livejournal.com\n"
+ "http://border.example.com/box/afterthought\n"
+ "oaic.gov.au\n"
+ "https://www.example.edu/base.php\n"
+ "house.gov\n"
+ "smh.com.au\n"
+ "http://www.example.edu/\n"
+ "https://www.example.org/\n"
+ "lycos.com\n"
+ "https://border.example.com/?bridge=basket&blood=animal\n"
+ "hibu.com\n"
+ "http://example.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}