re = /(\d+\) [A-Za-z+ ]+)/
str = '1) this is an example 2) another 15) still another'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end