package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,3}([ ,]?\d{3})*([.,]\d+)?$`)
var str = `valid
1000
1,000
1,000.00
1000.00
1,000,000.12
invalid
1000.00.00
1,0.00
1,000,00.00
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}