use strict;
my $str = 'valid
1000
1,000
1,000.00
1000.00
1,000,000.12
invalid
1000.00.00
1,0.00
1,000,00.00
';
my $regex = qr/^\d{1,3}([ ,]?\d{3})*([.,]\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}